OS/2 Guru - How to update OS/2 program for compatibility with ArcaOS?OS/2 Guru - How to update OS/2 program for compatibility with ArcaOS?

Welcome to eComStation.RU site!

Select your language: Russian English Deutch Spanish Italian Portuguese Czech Polish French

Frequently asked questions and answers:

OS/2 GURU

+7-981-8529467 (Санкт-Петербург)
ru · en · de · es · it · pt · cz · pl · fr
OS/2 is a greatly different operating system for PC (ArcaOS, eComStation, IBM OS/2 Warp)
Applications, news, reviews, support of users, hardware, questions and answers.
 
      What is OS/2?NewsInstallUpdateUsageFutureCommunityBuy    
**
(Map of the site)

 
 
Report: OS/2 compatible hardware

 
Update

 
Applications

 
Advantages:

 
For developer:

 
(Пайпы программ)

 
Companies:

 
History:

 
(Бонусы)

 
Advice:

 
(Барьеры и решения)

 
Technologies:

 
(Применение в науке, лаборатории, ..)

 

 
Solutions

 
New eComStation:

 
Future:

 
(Ссылки на другие сайты)

 
(Картинка дня)

 
OS/2 artefacts:

 
Gadgets:

<-- notizia precedente    notizia successiva -->

How to update OS/2 program for compatibility with ArcaOS?

  Date: 2020-01-09 03:12:08
Correspondent: Eugene Gorbunoff
Source: os2.guru
 

If your program was working in OS/2 Warp or eComStation, test that it is compatible with ArcaOS:

  • X-1: directory structure was changed. example: system files are located in \sys now
  • X-2: some aux utilities are absent or are located in other place. (example: pci.exe)
  • X-3: USBCALLS: should work as early (new apps compiled with ArcaOS, may fail in old eComStation. let's test)
  • X-4: if compiling XWP widget, then check X-1, X-2.
  • X-5: ACPI dll, (help us with tests)
  • X-7: the behavior of main drivers was changed 1) video: Panorama, 2) ACPI - test compatibility of your program with this drivers
  • test the installer of your program that it works without mistakes: X-1, X-2